An Animal Contest 1 P1 - Alpaca Shapes

View as PDF

Submit solution


Points: 3 (partial)
Time limit: 2.0s
Memory limit: 256M

Author:
Problem types

Today, Sam is learning all about circles and squares at school! Unfortunately, Sam is an alpaca and doesn't have a very good sense of size. As his best friend, you have been tasked with helping him determine the larger shape (it is guaranteed that one is larger than the other).

Note: The area of a square is defined as S^2 and the area of a circle is defined as 3.14 \times R^2.

Constraints

1 \le S,R \le 10^4

Input Specification

The first line will contain space-separated integers S and R, denoting the side length of the square and the radius of the circle respectively.

Output Specification

Output SQUARE if the area of the square is larger, and CIRCLE otherwise.

Sample Input 1

6 2

Sample Output 1

SQUARE

Explanation for Sample Output 1

The square has area 6^2=36, and the circle has area 3.14 \times 2^2=12.56. Therefore, the area of the square is larger.

Sample Input 2

12 124

Sample Output 2

CIRCLE

Comments


  • -17
    nguyenducquan123456  commented on Aug. 7, 2024, 2:53 p.m. edited

    This comment is hidden due to too much negative feedback. Show it anyway.


    • 0
      Stonks  commented on Oct. 30, 2024, 10:04 p.m.

      bro thought it was the submit solution page


    • 0
      HisMonDon  commented on Sept. 14, 2024, 10:20 p.m. edited

      ?


    • 5
      rfasta  commented on Aug. 7, 2024, 10:57 p.m.

      pls dont include your submission. it ruins the fun for the other people trying todo the problem.


  • -4
    sab5106  commented on July 29, 2024, 5:10 a.m.

    My code is correct. I have tested in my own IDE. How is DMOJ entering these values into my code? Would be useful to have a console output, or really anything more than just "wrong answer". Very frustrating and useless website.


    • 0
      HisMonDon  commented on Sept. 14, 2024, 10:29 p.m.

      print(shape_compare(input())) dont use debug mode in your IDE, your program has to print out the result


    • 1
      b_nary  commented on July 29, 2024, 5:26 a.m.

      You made a function and didn't even call it. How is your code "correct"?


  • 1
    BandB25  commented on Sept. 11, 2021, 4:36 p.m.

    Why is the second case not working?


    • 7
      dxke02  commented on Sept. 11, 2021, 4:51 p.m. edited

      X \text{^}Y does NOT mean X to the power of Y. It actually means X XOR Y.
      Many languages such as Python, Java, and C++ have built-in functions for raising numbers to powers. (such as pow in C++ and Math.pow in Java).
      However, writing your own exponentiation function is often preferred over using your languages built-in functions due to precision errors.


      • 2
        BandB25  commented on Sept. 12, 2021, 1:10 a.m.

        Thank you.