Today, Sam is learning all about circles and squares at school! Unfortunately, Sam is an alpaca and doesn't have a very good sense of size. As his best friend, you have been tasked with helping him determine the larger shape (it is guaranteed that one is larger than the other).
Note: The area of a square is defined as and the area of a circle is defined as .
Constraints
Input Specification
The first line will contain space-separated integers and , denoting the side length of the square and the radius of the circle respectively.
Output Specification
Output SQUARE
if the area of the square is larger, and CIRCLE
otherwise.
Sample Input 1
6 2
Sample Output 1
SQUARE
Explanation for Sample Output 1
The square has area , and the circle has area . Therefore, the area of the square is larger.
Sample Input 2
12 124
Sample Output 2
CIRCLE
Comments
This comment is hidden due to too much negative feedback. Show it anyway.
bro thought it was the submit solution page
?
pls dont include your submission. it ruins the fun for the other people trying todo the problem.
My code is correct. I have tested in my own IDE. How is DMOJ entering these values into my code? Would be useful to have a console output, or really anything more than just "wrong answer". Very frustrating and useless website.
print(shape_compare(input())) dont use debug mode in your IDE, your program has to print out the result
You made a function and didn't even call it. How is your code "correct"?
Why is the second case not working?
does NOT mean to the power of . It actually means XOR .
Many languages such as
Python
,Java
, andC++
have built-in functions for raising numbers to powers. (such aspow
inC++
andMath.pow
inJava
).However, writing your own exponentiation function is often preferred over using your languages built-in functions due to precision errors.
Thank you.