CCC '07 J1 - Who is in the Middle?

View as PDF

Submit solution

Points: 3
Time limit: 2.0s
Memory limit: 256M

Problem type
Canadian Computing Competition: 2007 Stage 1, Junior #1

In the story Goldilocks and the Three Bears, each bear had a bowl of porridge to eat while sitting at his/her favourite chair. What the story didn't tell us is that Goldilocks moved the bowls around on the table, so the bowls were not at the right seats anymore. The bowls can be sorted by weight with the lightest bowl being the Baby Bear's bowl, the medium bowl being the Mama Bear's bowl and the heaviest bowl being the Papa Bear's bowl.

Write a program that reads in three weights and prints out the weight of Mama Bear's bowl. You may assume all weights are positive integers less than 100.

Sample Input

10
5
8

Sample Output

8

Comments


  • 5
    Alb11747  commented on Oct. 21, 2022, 7:42 p.m.

    How is the fastest submission here python? kirbychin's answer took 0.001s. Is sys.stdin.readline() that much faster than input()? Or was this just a bug in the judging system?


  • 5
    Suergaz  commented on Dec. 1, 2021, 7:55 p.m.

    Was this prompt sort of a tongue twister for anyone else? "the lightest bowl being the baby bears bowl" had me reading it 3 times lol


  • 0
    sorenra7  commented on Sept. 28, 2021, 9:49 p.m. edited

    Can I assume the three weights will always be different?

    Edit: nevermind, after 2323423 tries, I got it.


  • 6
    RandomPplplusplus  commented on July 26, 2019, 4:33 a.m.

    dont use double, if u use double its gonna print something like 20.0


  • -92
    12weareunited  commented on Aug. 28, 2018, 2:47 p.m.

    This comment is hidden due to too much negative feedback. Show it anyway.


    • 7
      Super_User  commented on Dec. 29, 2019, 6:29 p.m.

      You cannot use doubles otherwise you would get a WA because a double would print out 8.0 as compared to an integer, which prints out 8; the correct answer.


      • -10
        karanmaheshwari  commented on July 26, 2020, 3:41 p.m.

        This comment is hidden due to too much negative feedback. Show it anyway.


        • 4
          Bevern  commented on Nov. 14, 2020, 9:32 p.m. edit 2

          A "double" has decimals, while integers don't. Float also has decimals, in this question, people are telling you to return integers instead of numbers with decimals, or you might get a wrong answer. Eg: 12.0 is a float/double, and 12 is an integer...


    • 28
      segfault  commented on Aug. 28, 2018, 3:19 p.m.

      Integers are fine.


      • -5
        VictorZhu  commented on March 23, 2022, 5:55 p.m.

        This comment is hidden due to too much negative feedback. Show it anyway.


        • -5
          henrybaolol9  commented on March 23, 2022, 6:17 p.m.

          This comment is hidden due to too much negative feedback. Show it anyway.