Canadian Computing Competition: 2007 Stage 1, Junior #1
In the story Goldilocks and the Three Bears, each bear had a bowl of porridge to eat while sitting at his/her favourite chair. What the story didn't tell us is that Goldilocks moved the bowls around on the table, so the bowls were not at the right seats anymore. The bowls can be sorted by weight with the lightest bowl being the Baby Bear's bowl, the medium bowl being the Mama Bear's bowl and the heaviest bowl being the Papa Bear's bowl.
Write a program that reads in three weights and prints out the weight of Mama Bear's bowl. You may assume all weights are positive integers less than .
Sample Input
10
5
8
Sample Output
8
Comments
How is the fastest submission here python? kirbychin's answer took 0.001s. Is
sys.stdin.readline()
that much faster thaninput()
? Or was this just a bug in the judging system?Was this prompt sort of a tongue twister for anyone else? "the lightest bowl being the baby bears bowl" had me reading it 3 times lol
Can I assume the three weights will always be different?
Edit: nevermind, after 2323423 tries, I got it.
dont use double, if u use double its gonna print something like 20.0
This comment is hidden due to too much negative feedback. Show it anyway.
You cannot use doubles otherwise you would get a
WA
because a double would print out 8.0 as compared to an integer, which prints out 8; the correct answer.This comment is hidden due to too much negative feedback. Show it anyway.
A "double" has decimals, while integers don't. Float also has decimals, in this question, people are telling you to return integers instead of numbers with decimals, or you might get a wrong answer. Eg: 12.0 is a float/double, and 12 is an integer...
Integers are fine.
This comment is hidden due to too much negative feedback. Show it anyway.
This comment is hidden due to too much negative feedback. Show it anyway.