The black foxen are the arch enemies of Tushan: they corrupt the love of reincarnated soulmates by absorbing their memories. This allows the black foxen to steal their pledge of love and the resulting spirit power.
The black foxen would like to prioritize a victim's memories, starting with the most important one. They have converted each memory to an integer, with up to 1 million digits (this will not fit in int data type). For this problem, the black foxen have hired you to compare two memories and print the one which is higher.
Given 2 non-negative integers and on different lines, where both and are less than . The number may contain leading zeros. If is larger than output S
, if is larger than output T
, otherwise output E
.
Sample Input
123456765434567652143783748374938274932798478329749328
0432874832787589275324893729562839478
Sample Output
S
Comments
Umm... Why is it that it says that I will get 5 points but I only got 2?
Read the about page.
How do you convert and into an integer?
Is there a command that inputs integers with up to 1 million digits?
Nevermind-fixed
s=int(input()) t=int(input())
of course number 4 is infinity and infinity
i finally finished
i used python
im so rusty at python
The constraints on this problem state the numbers in the input can be up to a hundred thousand digits long. Find a different way to store them, because they will certainly not fit in an int, long or float. Or a double, which I see you attempted to use after I commented.
I'm using python 3 and my code worked by inputing an integer normally with int(input()). It seems that the test cases do fit in an int.
Am i wrong?
Python int is a big int, in most languages though this isn't the case (c++, c, java, etc.)
y am i getting IRs
The number can be bigger than an int or a long
is java BigInteger allowed?
Yes