Valentine's Day '18 J1 - The Cactus Number

View as PDF

Submit solution


Points: 3 (partial)
Time limit: 1.0s
Memory limit: 64M

Author:
Problem type

Being a cuteness connoisseur, Carol has devised a system of measuring cuteness called "Carol Numbers", where one Carol number represents her own cuteness in a natural state.

Cactus numbers are said to represent ten times the cuteness as a Carol number. Some say that Cactus numbers do not exist, as a Carol number should be the highest conceivable value of cuteness. You will receive N Carol numbers, given in insignificant units as there are rarely Carol numbers above 1. One insignificant Carol is 1/1000 of a Carol. Is the Carol number truly the highest possible cuteness?

Constraints

1 \le N, K_i \le 10^6

Input Specification

The first line will contain N, the number of values.

Each of the following N lines will contain an integer K_i, representing the i^\text{th} Carol number, represented as cuteness in insignificant Carols.

Output Specification

If any Carol number above 10 exists, output Something is wrong with these cuteness values.

If any Carol number above 1 exists, but no Carol number above 10 exists, output Cuteness by definition is similarity to Cactus.

If no Carol numbers above 1 exist, output Cuteness by definition is similarity to Carol.

Sample Input 1

3
500
800
1000

Sample Output 1

Cuteness by definition is similarity to Carol

Sample Input 2

5
34
7564
345
654
2

Sample Output 2

Cuteness by definition is similarity to Cactus

Comments


  • 0
    candyappled  commented on Jan. 27, 2022, 2:07 a.m.

    I'm failing cases 2, 9, 13 and 15. Can someone tell me what's wrong?


    • 0
      Spitfire720  commented on Jan. 27, 2022, 1:45 p.m.

      Your code will fail when the max is 10000


  • 0
    Julien  commented on Jan. 9, 2020, 9:20 p.m.

    Does anyone know how I can get past a TLE?


    • 3
      Dingledooper  commented on Jan. 9, 2020, 11:46 p.m.

      Put these two lines at the beginning of your code. The input will be faster.

      import sys
      input = sys.stdin.readline