DMOPC '16 Contest 1 P0 - C.C. and Cheese-kun

View as PDF

Submit solution


Points: 3 (partial)
Time limit: 1.0s
Memory limit: 64M

Author:
Problem type

One summer evening, while curled up with her beloved Cheese-kun plushie, C.C. begins craving pizza. Although she would really like a large, extra-cheesy pizza, her stomach is willing to settle for anything. Without hesitation, she snatches up Lelouch's credit card and makes a very important phone call…

  • C.C. will be absolutely satisfied if the pizza she gets has a width of 3 units and an extra-cheesiness of at least 95\%.
  • C.C. will be fairly satisfied if the pizza she gets has a width of 1 unit and an extra-cheesiness of at most 50\%.
  • C.C. will be very satisfied with any other pizza she receives.

Input Specification

The first line of input will contain a single integer W (1 \le W \le 3), denoting the width of the pizza C.C. receives.

The second line of input will contain another integer C (0 \le C \le 100), representing the percentage of the pizza covered in extra cheese.

Output Specification

A single line containing C.C.'s satisfaction with her order in the form: C.C. is M satisfied with her pizza.

Make sure your output matches this exactly, including any spacing and punctuation.

Here, M is a string describing her satisfaction, which will be one of: absolutely, fairly or very.

Sample Input

2
70

Sample Output

C.C. is very satisfied with her pizza.

Explanation

The pizza has a width of 2 units and a cheesiness of 70\%. Since C.C. is neither absolutely nor fairly satisfied, she is very satisfied.


Comments


  • 0
    kevinduan2041  commented on March 19, 2024, 12:30 a.m.

    My test case #3 is wrong, can someone help me?


    • -1
      volcano  commented on March 19, 2024, 1:40 a.m.

      C.C. will be fairly satisfied if the pizza she gets has a width of 1 unit and an extra-cheesiness of at most 50\%.

      Not exactly 50\%.


  • -1
    JoeP  commented on Nov. 19, 2023, 12:59 p.m.

    My code for this problem delivers in test case #3 and #7 WA all other AC what's wrong?

    width = int(input())

    cheesins = int(input())

    if width == 1 and cheesins == 50:

    M = ('fairly')

    elif width == 3 and cheesins == 95:

    M = ('absolutely')

    else:

    M = ('very')

    print('C.C. is',M,'satisfied with her pizza.')

    Thanks in advance for your advice!

    JoeP


    • 0
      b_nary  commented on Nov. 19, 2023, 4:48 p.m.

      The words “at least 95%” and “at most 50%” in the instructions do not mean that the extra-cheesiness has to be exactly 95% or 50% for C.C to be absolutely or fairly satisfied